ubuntu14.04(amd64)安装Gaussion09+Gaussview | 寒山烟雨
现在的位置: 首页 > 滴水穿石 > 正文

ubuntu14.04(amd64)安装Gaussion09+Gaussview

2014年04月14日 滴水穿石 ⁄ 共 787字 ⁄ 字号 暂无评论 ⁄ 阅读 6,924 views 次

最近被各种软件的安装折腾的要死,慢慢记录下吧。

ubuntu12.*之后的版本都移除了ia32-libs库,对与gaussion安装没有什么问题,不过,Gview一般的版本都是x86的,需要自己手动添加依赖。

首先,修改.bashrc,在文件末尾添加:

 Bash | 
 
 copy code |
?

01
g09root=/home/hp
02
GAUSS_SCRDIR=/home/hp/g09/scratch
03
export g09root GAUSS_SCRDIR
04
. $g09root/g09/bsd/g09.profile
05
 
06
export GV_DIR=/home/hp/g09/gv/
07
export LIBPATH=/home/hp/g09/gv/lib
08
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/hp/g09/gv/lib
09
PATH=$PATH:/home/hp/g09/gv/
10

路径和版本号需要自己改。然后更新.bashrc:source  ~/.bashrc

然后执行下面的命令

 Bash | 
 
 copy code |
?

1
sudo -i
2
echo 0 >/proc/sys/kernel/randomize_va_space

安装依赖,12.*之前的系统可以直接通过安装ia32-libs支持,来解决gv的依赖问题,不过之后的版本要自己解决。最笨的方法是执行gview,会有提示缺失什么包,下面列出来了这些依赖,其中csh是32/64位系统都必须要安装的的:

 Text | 
 
 copy code |
?

1
csh
2
libfreetype6:i386
3
libglu1:i386
4
libxmu6:i386
5
libstdc++5:i386
6
libxrebder1:i386
7
libxrandr2:i386
8
libxcursor1:i386
9
libxft2:i386

之后,就可以在终端运行gview了。

PS:解决完上面的依赖,只需要再安装libglib2.0-0:i386,libcups2:i386两个依赖就可以直接安装wps了。

0

给我留言

留言无头像?


×